Access to SysTrack CE Cloud in Americas was inaccessible.
What was the root cause?
An approved and standard maintenance change led to a halt of processing of new sensors in the Americas region. Consequently, the team had to suspend the intake of additional sensors until the root cause was determined and resolved.
What is the Prevention Strategy?
Additional review process for maintenance deployments (Completed)
Additional alerting on the backend for earlier indicators of an issue (April 1)
Updating the Sensor agent upload mechanism to implement resends or retries. (TBD)
Posted Mar 17, 2025 - 13:31 UTC
Resolved
This incident has been resolved.
Posted Mar 10, 2025 - 13:52 UTC
Monitoring
A fix has been implemented and we monitoring the situation.
Posted Mar 10, 2025 - 12:04 UTC
Investigating
We are currently investigating reported issues with SysTrack Cloud availability in the below regions. Some users may not be able to use the SysTrack cloud UI, make API calls, or use third-party integrations that utilize the API. We're actively working on identifying the root cause. We apologize for any inconvenience and will provide an update once more details become available.