Some customers experienced issues connecting to all lakesidesoftware.com domains.
What was the root cause?
Our third-party DNS provider, Network Solutions, had an issue where DNS responses were not working for some edge locations on their Premium Service.
What is the Prevention Strategy?
As instructed by Network Solutions, moving our DNS off the Premium Service (managed by Comodo) until the issue is resolved (Completed)
Migrating back to Network Solution’s Premium Service (managed by Comodo) once the issue is resolved (Completed)
Evaluate change of service levels with Network Solutions, determine if internal or external alerts can be implemented, and research mitigation options including a new or redundant DNS provider based on key criteria including performance, reliability, security, and customer support (September 2025)
Posted Jul 29, 2025 - 19:27 UTC
Resolved
This incident has been resolved.
Posted Jul 11, 2025 - 21:00 UTC
Update
We have seen no more DNS errors from our observability platform. If you're still experiencing performance problems, please reach out to support@lakesidesoftware.com.
Posted Jul 11, 2025 - 19:23 UTC
Monitoring
We are aware of some customers having access accessing SysTrack CE. Our third party (Network Solutions - DNS) provider implemented a fix and we are seeing improvements. We will continue to monitor the situation.
Posted Jul 11, 2025 - 17:48 UTC
Update
We are aware of some customers having access accessing SysTrack CE. We are working with our third party (Network Solutions - DNS) provider to fix their underlaying infrastructure issue.
Posted Jul 11, 2025 - 17:28 UTC
Identified
We are aware of some customers having access accessing SysTrack CE. We are working with our third party (Network Solutions - DNS) provider to fix their underlaying infrastructure issue.