SAML SSO Issues against Regions

Incident Report for SysTrack Cloud Edition

Postmortem

What was the issue?

Less than 4% of our customers had login issues when using SAML SSO following the 11.2 upgrade.

What was the root cause?

During our standard SDLC, we updated a software package to its latest version. This update introduced stricter controls on the IDP Entity Setting, preventing login if customers didn't adhere to the recommended Entity setting.

What is the Prevention Strategy?

Lakeside

  1. worked directly with customers to update their SAML SSO Settings (Completed)
  2. will preform additional testing for library updates (On Going)
Posted Feb 06, 2025 - 13:35 UTC

Resolved

This incident has been resolved.
Posted Feb 03, 2025 - 18:41 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 03, 2025 - 15:15 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 03, 2025 - 15:15 UTC

Investigating

We are currently investigating issues logging in via SAML SSO.
Posted Feb 03, 2025 - 12:38 UTC
This incident affected: SysTrack Cloud Edition - Germany (SysTrack API/UI), SysTrack Cloud Edition - Americas (SysTrack API/UI), SysTrack Cloud Edition - Canada (SysTrack API/UI), SysTrack Cloud Edition - Australia (SysTrack API/UI), Lakeside Cloud Edition - UK (SysTrack API/UI), SysTrack Cloud Edition - France (SysTrack API/UI), SysTrack Cloud Edition - PWD (SysTrack API/UI), and SysTrack Cloud Edition - AB (SysTrack API/UI).