NLQ Agent Queries Issue

Incident Report for SysTrack Cloud Edition

Postmortem

What was the issue?

NLQ Agent queries responses could not be guaranteed to be processed. 

What was the root cause?

See Microsoft public RCA located here: https://azure.status.microsoft/en-us/status/history/ under “Preliminary Post Incident Review (PIR) - Azure Front Door - Connectivity issues across multiple regions”

What is the Prevention Strategy?

Design a failover back system if Azure Front Door is not available.

Posted Nov 07, 2025 - 17:02 UTC

Resolved

We have mitigated the issue and are working with our cloud provider to identify the root cause. If you are experiences any problems, please contact support.
Posted Oct 30, 2025 - 00:28 UTC

Monitoring

We are continuing to monitor the Azure recovery efforts.
Posted Oct 29, 2025 - 23:02 UTC

Update

We are monitoring the on going Azure outage for recovery.
Posted Oct 29, 2025 - 20:18 UTC

Identified

Only NLQ Agent queries are not processing data from the end points due to the ongoing Microsoft Azure Outage (YKYN-BWZ).
Posted Oct 29, 2025 - 16:00 UTC
This incident affected: SysTrack Cloud Edition - Americas (SysTrack Intelligence Package), Lakeside Cloud Edition - UK (SysTrack Intelligence Package), SysTrack Cloud Edition - Insiders (SysTrack Intelligence Package), SysTrack Cloud Edition - Optum (SysTrack Intelligence Package), and SysTrack Cloud Edition - Australia (SysTrack Intelligence Package).