Some customers experienced slowness when accessing the SysTrack CE UI in the America's region.
What was the root cause?
An under-layering resource was over utilized causes the slowness in the UI.
What is the Prevention Strategy?
Query data from the underlaying resource less often and implement cache where possible. (Completed)
Add additional alerting (12/1)
Posted Nov 07, 2025 - 17:02 UTC
Resolved
We have mitigated the issue and are working with our cloud provider to identify the root cause. If you are experiences any problems, please contact support.
Posted Oct 27, 2025 - 16:48 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 27, 2025 - 16:39 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 27, 2025 - 15:41 UTC
Update
We are continuing to investigate this issue.
Posted Oct 27, 2025 - 14:33 UTC
Investigating
Some slowness when using the SysTrack Cloud UI or while making API calls. We're actively working on identifying the root cause. We apologize for any inconvenience and will provide an update once more details become available
Posted Oct 27, 2025 - 13:34 UTC
This incident affected: SysTrack Cloud Edition - Americas (SysTrack API/UI).